summaryrefslogtreecommitdiffstats
path: root/libtransport/src/hicn/transport/CMakeLists.txt
diff options
context:
space:
mode:
authorMichele Papalini <micpapal@cisco.com>2019-10-22 11:02:00 +0000
committerGerrit Code Review <gerrit@fd.io>2019-10-22 11:02:00 +0000
commitda59c2cb5c809d3e8b2cffc6668199d393793a9d (patch)
tree3c01bba4e1cddea34ffcfb10e0c87ca57f4a37b8 /libtransport/src/hicn/transport/CMakeLists.txt
parentc37f17534d4f7eaab692a5ffb252858d48358679 (diff)
parent7429211aee3daa4227e10d2541920c0dea785191 (diff)
Merge "[HICN-346] Add version of the transport library in the config.h header file."
Diffstat (limited to 'libtransport/src/hicn/transport/CMakeLists.txt')
-rw-r--r--libtransport/src/hicn/transport/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/libtransport/src/hicn/transport/CMakeLists.txt b/libtransport/src/hicn/transport/CMakeLists.txt
index 6e0ae5b88..22acdcb7f 100644
--- a/libtransport/src/hicn/transport/CMakeLists.txt
+++ b/libtransport/src/hicn/transport/CMakeLists.txt
@@ -25,6 +25,8 @@ add_subdirectory(portability)
add_subdirectory(protocols)
add_subdirectory(utils)
+include(Packager)
+extract_version()
configure_file("config.h.in" "config.h" @ONLY)
install(
FILES ${CMAKE_CURRENT_BINARY_DIR}/config.h