aboutsummaryrefslogtreecommitdiffstats
path: root/telemetry/vpp-collectd/vpp-hicn/CMakeLists.txt
diff options
context:
space:
mode:
authorOlivier Roques <oroques+fdio@cisco.com>2020-11-19 09:36:59 +0000
committerMauro Sardara <msardara@cisco.com>2021-01-19 13:11:04 +0000
commit12085f96264835de7fb2fb607e57edcef603346c (patch)
tree51887fe8e2660a9cc6591f66aa8747a4c139a271 /telemetry/vpp-collectd/vpp-hicn/CMakeLists.txt
parent3723df3455e88e8534041d1a29b12e8d4a72bb98 (diff)
[HICN-657] Remove common.h dependency in collectd plugins
In Ubuntu 20.04, the file common.h is not shipped with collectd packages anymore. This patch removes that dependency from the collectd plugins. Change-Id: I234389ee9cbfd1f1820efdb34d532a7b11618206 Signed-off-by: Olivier Roques <oroques+fdio@cisco.com>
Diffstat (limited to 'telemetry/vpp-collectd/vpp-hicn/CMakeLists.txt')
-rw-r--r--telemetry/vpp-collectd/vpp-hicn/CMakeLists.txt9
1 files changed, 4 insertions, 5 deletions
diff --git a/telemetry/vpp-collectd/vpp-hicn/CMakeLists.txt b/telemetry/vpp-collectd/vpp-hicn/CMakeLists.txt
index fc39b9385..3703515dc 100644
--- a/telemetry/vpp-collectd/vpp-hicn/CMakeLists.txt
+++ b/telemetry/vpp-collectd/vpp-hicn/CMakeLists.txt
@@ -18,7 +18,7 @@ find_package(Collectd REQUIRED)
find_package(Vpp REQUIRED)
if(${CMAKE_SOURCE_DIR}/vpp-collectd STREQUAL ${PROJECT_SOURCE_DIR})
- message (STATUS "not compiling in the same folder")
+ message (STATUS "not compiling in the same folder")
find_package(HicnPlugin REQUIRED)
find_package(VapiSafe REQUIRED)
else()
@@ -29,17 +29,16 @@ else()
endif()
list(APPEND SOURCE_FILES
- ${CMAKE_CURRENT_SOURCE_DIR}/vpp_hicn.c
-)
+ ${CMAKE_CURRENT_SOURCE_DIR}/vpp_hicn.c)
-list (APPEND INCLUDE_DIRS
+list(APPEND INCLUDE_DIRS
${COLLECTD_INCLUDE_DIRS}
${HICNPLUGIN_INCLUDE_DIRS}
${SAFE_VAPI_INCLUDE_DIRS}
${VPP_INCLUDE_DIRS}
${CMAKE_CURRENT_SOURCE_DIR})
-list (APPEND LIBRARIES
+list(APPEND LIBRARIES
${VPP_LIBRARY_VAPICLIENT}
${SAFE_VAPI_LIBRARIES})