aboutsummaryrefslogtreecommitdiffstats
path: root/utils/CMakeLists.txt
diff options
context:
space:
mode:
authorAngelo Mantellini <angelo.mantellini@cisco.com>2020-03-31 11:10:00 +0000
committerGerrit Code Review <gerrit@fd.io>2020-03-31 11:10:00 +0000
commit23c3bb7400839b664096ad5e16a2346386109bda (patch)
treed1999acef9f91cd25db9b7c63fd2963cd7ba0e57 /utils/CMakeLists.txt
parentd46e59824bd3fc67abe7bd725965aa454942d640 (diff)
parent3718e549ee31ac764b327bbf3d6e51dd7e224b46 (diff)
Merge "[HICN-581] update hicn stack to support windows, again"
Diffstat (limited to 'utils/CMakeLists.txt')
-rw-r--r--utils/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/utils/CMakeLists.txt b/utils/CMakeLists.txt
index 3e99fbae2..d82425236 100644
--- a/utils/CMakeLists.txt
+++ b/utils/CMakeLists.txt
@@ -35,7 +35,7 @@ set(HICN_UTILS hicn-utils CACHE INTERNAL "" FORCE)
if(CMAKE_SOURCE_DIR STREQUAL PROJECT_SOURCE_DIR)
find_package(Libtransport REQUIRED)
else()
- if (${CMAKE_SYSTEM_NAME} STREQUAL "Android")
+ if (DISABLE_SHARED_LIBRARIES)
set(LIBTRANSPORT_LIBRARIES ${LIBTRANSPORT_STATIC})
set(DEPENDENCIES ${LIBTRANSPORT_STATIC})
else ()