summaryrefslogtreecommitdiffstats
path: root/utils/CMakeLists.txt
diff options
context:
space:
mode:
authorAngelo Mantellini <manangel@cisco.com>2019-01-31 10:36:54 +0100
committerAngelo Mantellini <manangel@cisco.com>2019-01-31 11:17:49 +0100
commit7b61129b2ed89d2cc3ca5560f55c26c6c347a215 (patch)
tree5c2433fdcc0447f05f79a981a6e8287e61182038 /utils/CMakeLists.txt
parent67371907c2433f5233d4a669a1c9176539e9928f (diff)
[HICN-20] This source upgrade allows to compile ping_client, ping_server and hiperf (utils folder) in Windows.
Change-Id: I8253aa9aa640644b0daffd95dff202956371d814 Signed-off-by: Angelo Mantellini <manangel@cisco.com>
Diffstat (limited to 'utils/CMakeLists.txt')
-rw-r--r--utils/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/utils/CMakeLists.txt b/utils/CMakeLists.txt
index 9d05942ed..a377132e1 100644
--- a/utils/CMakeLists.txt
+++ b/utils/CMakeLists.txt
@@ -23,6 +23,7 @@ set(CMAKE_MODULE_PATH
)
include(BuildMacros)
+include(WindowsMacros)
if(CMAKE_SOURCE_DIR STREQUAL PROJECT_SOURCE_DIR)
find_package(Libtransport REQUIRED)
@@ -51,5 +52,6 @@ foreach(util ${UTILS_SRC})
DEPENDS ${LIBTRANSPORT}
COMPONENT hicn-utils
DEFINITIONS ${COMPILER_DEFINITIONS}
+ LINK_LIBRARIES ${WSOCK32_LIBRARY} ${WS2_32_LIBRARY}
)
endforeach() \ No newline at end of file