summaryrefslogtreecommitdiffstats
path: root/utils/CMakeLists.txt
diff options
context:
space:
mode:
authorMauro Sardara <msardara@cisco.com>2019-02-01 17:12:38 +0100
committerMauro Sardara <msardara@cisco.com>2019-02-01 18:41:39 +0100
commite8fabe3f6313a3b9050fe16458e4714d9dce426e (patch)
treeb379acde21e48a0f2e047d47f79ea30e8d43bd80 /utils/CMakeLists.txt
parentc00bc6fc2af9a54fe339f8d6a3ec1ab889c2931e (diff)
[HICN-10] Compile libtransport with libmemif support
Change-Id: I81d1cb4d5f16a61c35f66fe347985f05d8c97383 Signed-off-by: Mauro Sardara <msardara@cisco.com>
Diffstat (limited to 'utils/CMakeLists.txt')
-rw-r--r--utils/CMakeLists.txt7
1 files changed, 3 insertions, 4 deletions
diff --git a/utils/CMakeLists.txt b/utils/CMakeLists.txt
index a377132e1..077789f57 100644
--- a/utils/CMakeLists.txt
+++ b/utils/CMakeLists.txt
@@ -29,7 +29,7 @@ if(CMAKE_SOURCE_DIR STREQUAL PROJECT_SOURCE_DIR)
find_package(Libtransport REQUIRED)
set(HICN_UTILS hicn-utils)
else()
- set(LIBTRANSPORT_LIBRARIES ${LIBTRANSPORT})
+ set(LIBTRANSPORT_LIBRARIES ${LIBTRANSPORT_SHARED})
endif()
include(Packaging)
@@ -48,10 +48,9 @@ foreach(util ${UTILS_SRC})
build_executable(${util_name}
SOURCES ${util}
- LINK_LIBRARIES ${LIBTRANSPORT_LIBRARIES}
+ LINK_LIBRARIES ${LIBTRANSPORT_LIBRARIES} ${WSOCK32_LIBRARY} ${WS2_32_LIBRARY}
DEPENDS ${LIBTRANSPORT}
- COMPONENT hicn-utils
+ COMPONENT ${HICN_UTILS}
DEFINITIONS ${COMPILER_DEFINITIONS}
- LINK_LIBRARIES ${WSOCK32_LIBRARY} ${WS2_32_LIBRARY}
)
endforeach() \ No newline at end of file