summaryrefslogtreecommitdiffstats
path: root/utils/sysrepo-plugins/CMakeLists.txt
diff options
context:
space:
mode:
authorMasoud Hemmatpour <mhemmatp@cisco.com>2019-03-08 13:40:22 +0100
committerMasoud Hemmatpour <mhemmatp@cisco.com>2019-03-25 15:45:35 +0100
commitc405a5bb3a2299c34f11431be477a228715e66fa (patch)
tree1dabcddbc14dfb010efb22a1547c30f00a03c98e /utils/sysrepo-plugins/CMakeLists.txt
parent558581790763815071e9c77e06047e689faf752f (diff)
[HICN-90] adding hicn-light to sysrepo-plugins
Change-Id: Icd92adb21661d33b0cd40ea8c3dd748f0fa97aaf Signed-off-by: Masoud Hemmatpour <mhemmatp@cisco.com> Signed-off-by: Luca Muscariello <lumuscar+fdio@cisco.com> Signed-off-by: Masoud Hemmatpour <mhemmatp@cisco.com>
Diffstat (limited to 'utils/sysrepo-plugins/CMakeLists.txt')
-rw-r--r--utils/sysrepo-plugins/CMakeLists.txt40
1 files changed, 40 insertions, 0 deletions
diff --git a/utils/sysrepo-plugins/CMakeLists.txt b/utils/sysrepo-plugins/CMakeLists.txt
new file mode 100644
index 000000000..91726161f
--- /dev/null
+++ b/utils/sysrepo-plugins/CMakeLists.txt
@@ -0,0 +1,40 @@
+#
+# Copyright (c) 2019 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+#
+
+cmake_minimum_required(VERSION 3.5 FATAL_ERROR)
+project(hicn_sysrepo_plugin)
+
+include(GNUInstallDirs)
+
+set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
+
+# set default build type if not specified by user
+if(NOT CMAKE_BUILD_TYPE)
+ set(CMAKE_BUILD_TYPE debug)
+endif()
+string(TOLOWER "${CMAKE_BUILD_TYPE}" CMAKE_BUILD_TYPE_LOWER)
+
+# set compiler options
+set(CMAKE_EXPORT_COMPILE_COMMANDS 1)
+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall -std=gnu99")
+set(CMAKE_C_FLAGS_RELEASE "-DNDEBUG -O2")
+set(CMAKE_C_FLAGS_DEBUG "-g -O0")
+
+# add subdirectories
+add_subdirectory(hicn-plugin)
+add_subdirectory(hicn-light)
+include(Packaging)
+include(Packager)
+make_packages()