aboutsummaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 77dcbb6d8..afbd45f21 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -25,13 +25,18 @@ option(BUILD_HICNLIGHT "Build the hicn light forwarder" ON)
option(BUILD_LIBTRANSPORT "Build the hicn transport library" ON)
option(BUILD_UTILS "Build the hicn utils" ON)
option(BUILD_APPS "Build the hicn apps" OFF)
-option(BUILD_CTRL "Build the hicn control tools" ON)
+if (NOT WIN32)
+ option(BUILD_CTRL "Build the hicn control tools" ON)
+ option(DISABLE_SHARED_LIBRARIES "Disable shared libraries" OFF)
+else ()
+ option(BUILD_CTRL "Build the hicn control tools" OFF)
+ option(DISABLE_SHARED_LIBRARIES "Disable shared libraries" ON)
+endif ()
option(BUILD_HICNPLUGIN "Build the hicn vpp plugin" OFF)
option(BUILD_SYSREPOPLUGIN "Build the sysrepo plugin" OFF)
option(BUILD_EXTRAS "Build external projects" OFF)
option(BUILD_TELEMETRY "Build telemetry projects" OFF)
option(DISABLE_EXECUTABLES "Disable executables" OFF)
-option(DISABLE_SHARED_LIBRARIES "Disable shared libraries" OFF)
if ((BUILD_APPS OR BUILD_UTILS) AND NOT BUILD_LIBTRANSPORT)
message(STATUS "Libhicntransport required. Enabled by default.")