summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 34105c7f7..37d232ea0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -63,7 +63,7 @@ endforeach()
## Static targets
set(LIBHICN hicn)
-set(LIBHICN_LIGHT hicn-light)
+set(HICN_LIGHT hicn-light)
set(HICN_LIGHT_CONTROL hicn-light-control)
set(HICN_LIGHT_DAEMON hicn-light-daemon)
set(HICN_PLUGIN hicn-plugin)
@@ -91,10 +91,13 @@ if (BUILD_HICNEXTRAPLUGIN AND "${CMAKE_SYSTEM_NAME}" STREQUAL "Linux")
)
endif()
-## Shared targets
+## Libraries targets
set(LIBHICN_SHARED ${LIBHICN}.shared)
set(LIBTRANSPORT_SHARED ${LIBTRANSPORT}.shared)
+set(LIBHICN_STATIC ${LIBHICN}.static)
+set(LIBTRANSPORT_STATIC ${LIBTRANSPORT}.static)
+
if (NOT WIN32)
add_compile_options(-Wall -Werror)
endif ()