aboutsummaryrefslogtreecommitdiffstats
path: root/apps/higet/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'apps/higet/CMakeLists.txt')
-rw-r--r--apps/higet/CMakeLists.txt18
1 files changed, 10 insertions, 8 deletions
diff --git a/apps/higet/CMakeLists.txt b/apps/higet/CMakeLists.txt
index 76814384d..1cf14c287 100644
--- a/apps/higet/CMakeLists.txt
+++ b/apps/higet/CMakeLists.txt
@@ -31,11 +31,13 @@ list(APPEND APPS_SRC
higet.cc
)
-build_executable(${HIGET}
- SOURCES ${APPS_SRC}
- LINK_LIBRARIES ${LIBTRANSPORT_LIBRARIES} ${WSOCK32_LIBRARY} ${WS2_32_LIBRARY}
- DEPENDS ${LIBTRANSPORT_LIBRARIES}
- COMPONENT ${HICN_APPS}
- DEFINITIONS ${COMPILER_DEFINITIONS}
- LINK_FLAGS ${LINK_FLAGS}
-)
+if (NOT DISABLE_EXECUTABLES)
+ build_executable(${HIGET}
+ SOURCES ${APPS_SRC}
+ LINK_LIBRARIES ${LIBTRANSPORT_LIBRARIES} ${WSOCK32_LIBRARY} ${WS2_32_LIBRARY}
+ DEPENDS ${LIBTRANSPORT_LIBRARIES}
+ COMPONENT ${HICN_APPS}
+ DEFINITIONS ${COMPILER_DEFINITIONS}
+ LINK_FLAGS ${LINK_FLAGS}
+ )
+endif ()