aboutsummaryrefslogtreecommitdiffstats
path: root/apps/http-server/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'apps/http-server/CMakeLists.txt')
-rw-r--r--apps/http-server/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/apps/http-server/CMakeLists.txt b/apps/http-server/CMakeLists.txt
index bedb6afc1..a39cb8366 100644
--- a/apps/http-server/CMakeLists.txt
+++ b/apps/http-server/CMakeLists.txt
@@ -20,6 +20,11 @@ list(APPEND LIBRARIES
${CURL_LIBRARY}
)
+if (NOT CMAKE_BUILD_TYPE)
+ message(STATUS "No build type selected, default to Release")
+ set(CMAKE_BUILD_TYPE "Release")
+endif ()
+
set(LIB_SOURCE_FILES
http-server/http_server.cc
http-server/response.cc