aboutsummaryrefslogtreecommitdiffstats
path: root/ctrl/facemgr/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ctrl/facemgr/src/CMakeLists.txt')
-rw-r--r--ctrl/facemgr/src/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/ctrl/facemgr/src/CMakeLists.txt b/ctrl/facemgr/src/CMakeLists.txt
index f99e57e07..88f554c40 100644
--- a/ctrl/facemgr/src/CMakeLists.txt
+++ b/ctrl/facemgr/src/CMakeLists.txt
@@ -24,6 +24,7 @@ set(HEADER_FILES
error.h
facelet.h
interface.h
+ loop.h
util/hash.h
util/map.h
util/set.h
@@ -32,12 +33,27 @@ set(HEADER_FILES
set(SOURCE_FILES
api.c
cfg.c
+ cfg_file.c
error.c
facelet.c
interface.c
util/log.c
)
+if(APPLE)
+set(SOURCE_FILES
+ ${SOURCE_FILES}
+ loop_dispatcher.c
+)
+endif()
+
+if (LINUX)
+set(SOURCE_FILES
+ ${SOURCE_FILES}
+ loop_libevent.c
+)
+endif()
+
set(INCLUDE_DIRS
./
../includes/