summaryrefslogtreecommitdiffstats
path: root/ctrl/libhicnctrl/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ctrl/libhicnctrl/CMakeLists.txt')
-rw-r--r--ctrl/libhicnctrl/CMakeLists.txt53
1 files changed, 53 insertions, 0 deletions
diff --git a/ctrl/libhicnctrl/CMakeLists.txt b/ctrl/libhicnctrl/CMakeLists.txt
new file mode 100644
index 000000000..3a2358f65
--- /dev/null
+++ b/ctrl/libhicnctrl/CMakeLists.txt
@@ -0,0 +1,53 @@
+# Copyright (c) 2017-2019 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+cmake_minimum_required(VERSION 3.5 FATAL_ERROR)
+
+project(libhicnctrl)
+
+if (NOT CMAKE_BUILD_TYPE)
+ message(STATUS "No build type selected, default to Release")
+ set(CMAKE_BUILD_TYPE "Release")
+endif()
+
+set(CMAKE_MODULE_PATH
+ ${CMAKE_MODULE_PATH}
+ "${CMAKE_CURRENT_SOURCE_DIR}/../../cmake/Modules"
+ "${CMAKE_CURRENT_SOURCE_DIR}/cmake/Modules"
+)
+
+set(CMAKE_C_STANDARD 11)
+set(CMAKE_C_STANDARD_REQUIRED ON)
+
+set(CMAKE_MACOSX_RPATH ON)
+
+if(CMAKE_SOURCE_DIR STREQUAL PROJECT_SOURCE_DIR)
+ set(HICN_CTRL hicn-ctrl)
+ set(LIBHICN_CTRL hicn-ctrl)
+ set(LIBHICN_CTRL_SHARED ${LIBHICNCTRL}.shared)
+ set(LIBHICN_CTRL_STATIC ${LIBHICNCTRL}.static)
+endif()
+
+set(LIBHICNCTRL_COMPONENT lib${LIBHICN_CTRL})
+
+set(TO_INSTALL_HEADER_FILES)
+
+add_subdirectory(includes)
+add_subdirectory(src)
+
+include(Packaging)
+
+if(CMAKE_SOURCE_DIR STREQUAL PROJECT_SOURCE_DIR)
+ include(Packager)
+ make_packages()
+endif()