aboutsummaryrefslogtreecommitdiffstats
path: root/ctrl/sysrepo-plugins/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'ctrl/sysrepo-plugins/CMakeLists.txt')
-rw-r--r--ctrl/sysrepo-plugins/CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/ctrl/sysrepo-plugins/CMakeLists.txt b/ctrl/sysrepo-plugins/CMakeLists.txt
index 1a9bca18c..8c1278c1c 100644
--- a/ctrl/sysrepo-plugins/CMakeLists.txt
+++ b/ctrl/sysrepo-plugins/CMakeLists.txt
@@ -41,14 +41,12 @@ if (NOT SRPD_PLUGINS_PATH)
message(FATAL_ERROR "Cannot get sysrepo plugins directory due to missing pkg-config, set SRPD_PLUGINS_PATH manually.")
endif()
+find_package(Vpp REQUIRED)
+
if(CMAKE_SOURCE_DIR STREQUAL PROJECT_SOURCE_DIR)
- find_package(Vpp REQUIRED)
find_package(HicnPlugin REQUIRED)
- find_package(Libhicn REQUIRED)
else()
list(APPEND DEPENDENCIES
- ${LIBHICN_SHARED}
- ${LIBHICN_STATIC}
hicn_plugin
)
endif()