aboutsummaryrefslogtreecommitdiffstats
path: root/hicn-light/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'hicn-light/CMakeLists.txt')
-rw-r--r--hicn-light/CMakeLists.txt10
1 files changed, 8 insertions, 2 deletions
diff --git a/hicn-light/CMakeLists.txt b/hicn-light/CMakeLists.txt
index 1e5805d68..a632380fc 100644
--- a/hicn-light/CMakeLists.txt
+++ b/hicn-light/CMakeLists.txt
@@ -39,7 +39,6 @@ if(NOT WIN32)
else ()
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} /wd4996")
endif ()
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -g")
if(${CMAKE_SYSTEM_NAME} STREQUAL "Android")
message("############ Detected cross compile for $ENV{CMAKE_SYSTEM_NAME}")
@@ -72,7 +71,7 @@ else()
endif ()
endif()
-include( Packaging )
+include(Packaging)
find_package(Threads REQUIRED)
@@ -108,3 +107,10 @@ if("${CMAKE_CXX_COMPILER_ID}" STREQUAL "AppleClang")
endif()
add_subdirectory(src/hicn)
+
+# Install service file in linux systems
+include(ServiceScript)
+install_service_script(
+ ${CMAKE_CURRENT_SOURCE_DIR}/config/hicn-light.service
+ COMPONENT ${HICN_LIGHT}
+) \ No newline at end of file