summaryrefslogtreecommitdiffstats
path: root/hicn-light/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'hicn-light/CMakeLists.txt')
-rw-r--r--hicn-light/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/hicn-light/CMakeLists.txt b/hicn-light/CMakeLists.txt
index c8579c70b..7df740b4c 100644
--- a/hicn-light/CMakeLists.txt
+++ b/hicn-light/CMakeLists.txt
@@ -21,7 +21,9 @@ include( detectCacheSize )
if(NOT WIN32)
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall")
-endif()
+else ()
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} /wd4996")
+endif ()
if(ANDROID_API)
message("############ Detected cross compile for $ENV{CMAKE_SYSTEM_NAME}")
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${ANDROID_C_FLAGS}")