summaryrefslogtreecommitdiffstats
path: root/hicn-light/src/hicn/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'hicn-light/src/hicn/CMakeLists.txt')
-rw-r--r--hicn-light/src/hicn/CMakeLists.txt25
1 files changed, 15 insertions, 10 deletions
diff --git a/hicn-light/src/hicn/CMakeLists.txt b/hicn-light/src/hicn/CMakeLists.txt
index a9861c32d..0f711e353 100644
--- a/hicn-light/src/hicn/CMakeLists.txt
+++ b/hicn-light/src/hicn/CMakeLists.txt
@@ -3,6 +3,18 @@
include(BuildMacros)
configure_file(config.h.in hicn-light/config.h @ONLY)
+if("${CMAKE_SYSTEM_NAME}" STREQUAL "Linux" AND ENABLE_PUNTING)
+ list(APPEND COMPILER_DEFINITIONS
+ "-DPUNTING"
+ )
+endif()
+
+list(APPEND COMPILER_DEFINITIONS
+ "-DWITH_MAPME"
+ "-DWITH_POLICY"
+)
+
+
if(NOT ANDROID_API AND NOT COMPILE_FOR_IOS)
add_subdirectory(command_line)
endif ()
@@ -22,16 +34,6 @@ list(APPEND HEADER_FILES
${CMAKE_CURRENT_BINARY_DIR}/hicn-light/config.h
)
-if("${CMAKE_SYSTEM_NAME}" STREQUAL "Linux" AND ENABLE_PUNTING)
- list(APPEND COMPILER_DEFINITIONS
- "-DPUNTING"
- )
-endif()
-
-list(APPEND COMPILER_DEFINITIONS
- "-DWITH_MAPME -DWITH_MAPME_FIXES"
-)
-
list(INSERT HICN_LIGHT_INCLUDE_DIRS 0
${CMAKE_CURRENT_SOURCE_DIR}/..
${CMAKE_CURRENT_BINARY_DIR}/..
@@ -41,6 +43,9 @@ list(APPEND TO_INSTALL_HEADER_FILES
${CMAKE_CURRENT_BINARY_DIR}/hicn-light/config.h
)
+set(TO_INSTALL_HEADER_FILES
+)
+
if (ANDROID_API)
build_library(${LIBHICN_LIGHT}
STATIC