summaryrefslogtreecommitdiffstats
path: root/hicn-light/src/hicn/api/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'hicn-light/src/hicn/api/CMakeLists.txt')
-rw-r--r--hicn-light/src/hicn/api/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/hicn-light/src/hicn/api/CMakeLists.txt b/hicn-light/src/hicn/api/CMakeLists.txt
new file mode 100644
index 000000000..c8bf16ff3
--- /dev/null
+++ b/hicn-light/src/hicn/api/CMakeLists.txt
@@ -0,0 +1,36 @@
+# Copyright (c) 2017-2019 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+cmake_minimum_required(VERSION 3.5 FATAL_ERROR)
+
+set(HEADER_FILES
+ ${CMAKE_CURRENT_SOURCE_DIR}/api.h
+ ${CMAKE_CURRENT_SOURCE_DIR}/commands.h
+ ${CMAKE_CURRENT_SOURCE_DIR}/face.h
+ ${CMAKE_CURRENT_SOURCE_DIR}/ip_address.h
+ ${CMAKE_CURRENT_SOURCE_DIR}/token.h
+ ${CMAKE_CURRENT_SOURCE_DIR}/types.h
+)
+
+set(SOURCE_FILES
+ ${CMAKE_CURRENT_SOURCE_DIR}/api.c
+)
+
+build_library(hicn-light-ctrl
+ SHARED
+ SOURCES ${SOURCE_FILES}
+ COMPONENT ${HICN_LIGHT}
+ INSTALL_ROOT_DIR hicn
+ INSTALL_HEADERS ${HEADER_FILES}
+ LINK_LIBRARIES ${HICN_LIGHT_LINK_LIBRARIES}
+) \ No newline at end of file