aboutsummaryrefslogtreecommitdiffstats
path: root/hicn-light/src/strategies/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'hicn-light/src/strategies/CMakeLists.txt')
-rw-r--r--hicn-light/src/strategies/CMakeLists.txt36
1 files changed, 0 insertions, 36 deletions
diff --git a/hicn-light/src/strategies/CMakeLists.txt b/hicn-light/src/strategies/CMakeLists.txt
deleted file mode 100644
index 7f0730b2f..000000000
--- a/hicn-light/src/strategies/CMakeLists.txt
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright (c) 2017-2019 Cisco and/or its affiliates.
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at:
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-cmake_minimum_required(VERSION 3.5 FATAL_ERROR)
-
-list(APPEND HEADER_FILES
- ${CMAKE_CURRENT_SOURCE_DIR}/strategyImpl.h
- ${CMAKE_CURRENT_SOURCE_DIR}/loadBalancer.h
- ${CMAKE_CURRENT_SOURCE_DIR}/loadBalancerWithPD.h
- ${CMAKE_CURRENT_SOURCE_DIR}/nexthopState.h
- ${CMAKE_CURRENT_SOURCE_DIR}/nexthopStateWithPD.h
- ${CMAKE_CURRENT_SOURCE_DIR}/rnd.h
- ${CMAKE_CURRENT_SOURCE_DIR}/rndSegment.h
-)
-
-list(APPEND SOURCE_FILES
- ${CMAKE_CURRENT_SOURCE_DIR}/loadBalancer.c
- ${CMAKE_CURRENT_SOURCE_DIR}/loadBalancerWithPD.c
- ${CMAKE_CURRENT_SOURCE_DIR}/nexthopState.c
- ${CMAKE_CURRENT_SOURCE_DIR}/nexthopStateWithPD.c
- ${CMAKE_CURRENT_SOURCE_DIR}/rnd.c
- ${CMAKE_CURRENT_SOURCE_DIR}/rndSegment.c
-)
-
-set(SOURCE_FILES ${SOURCE_FILES} PARENT_SCOPE)
-set(HEADER_FILES ${HEADER_FILES} PARENT_SCOPE)