summaryrefslogtreecommitdiffstats
path: root/lib/doc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/doc/CMakeLists.txt')
-rw-r--r--lib/doc/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/doc/CMakeLists.txt b/lib/doc/CMakeLists.txt
index cf022dc52..9b4660337 100644
--- a/lib/doc/CMakeLists.txt
+++ b/lib/doc/CMakeLists.txt
@@ -7,6 +7,7 @@ if(BUILD_DOCUMENTATION)
message(FATAL_ERROR "Doxygen is needed to build the documentation.")
endif()
+ set(doxy_main_page ${CMAKE_CURRENT_SOURCE_DIR}/../README.md)
set(doxyfile_in ${CMAKE_CURRENT_SOURCE_DIR}/Doxyfile.in)
set(doxyfile ${CMAKE_CURRENT_BINARY_DIR}/Doxyfile)
@@ -18,6 +19,5 @@ if(BUILD_DOCUMENTATION)
COMMENT "Generating API documentation with Doxygen"
VERBATIM)
-# FIXME MS : wrong install path
- install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/html DESTINATION share/doc)
+ install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/html DESTINATION share/doc OPTIONAL)
endif()