summaryrefslogtreecommitdiffstats
path: root/libtransport/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libtransport/CMakeLists.txt')
-rw-r--r--libtransport/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/libtransport/CMakeLists.txt b/libtransport/CMakeLists.txt
index 131067888..1cc4c3539 100644
--- a/libtransport/CMakeLists.txt
+++ b/libtransport/CMakeLists.txt
@@ -29,6 +29,19 @@ if (NOT CMAKE_BUILD_TYPE)
set(CMAKE_BUILD_TYPE "Release")
endif ()
+#########################################
+# LOG LEVELS AVAILABLE
+# VERBOSE
+# DEBUG
+# INFO
+# WARN
+# ERROR
+# FATAL
+# NONE
+#
+# Default: INFO
+set(TRANSPORT_LOG_LEVEL "INFO" CACHE STRING "Set log level")
+
set(TRANSPORT_ROOT_PATH "src/hicn/transport")
set(TRANSPORT_CORE ${TRANSPORT_ROOT_PATH}/core)