summaryrefslogtreecommitdiffstats
path: root/utils/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'utils/CMakeLists.txt')
-rwxr-xr-xutils/CMakeLists.txt9
1 files changed, 5 insertions, 4 deletions
diff --git a/utils/CMakeLists.txt b/utils/CMakeLists.txt
index 95fdd508d..9d05942ed 100755
--- a/utils/CMakeLists.txt
+++ b/utils/CMakeLists.txt
@@ -23,15 +23,16 @@ set(CMAKE_MODULE_PATH
)
include(BuildMacros)
-include(Packager)
if(CMAKE_SOURCE_DIR STREQUAL PROJECT_SOURCE_DIR)
find_package(Libtransport REQUIRED)
+ set(HICN_UTILS hicn-utils)
else()
- # TODO Set name of targets in CMakeroot file
set(LIBTRANSPORT_LIBRARIES ${LIBTRANSPORT})
endif()
+include(Packaging)
+
set (COMPILER_DEFINITIONS "-DASIO_STANDALONE")
list(APPEND UTILS_SRC
@@ -47,8 +48,8 @@ foreach(util ${UTILS_SRC})
build_executable(${util_name}
SOURCES ${util}
LINK_LIBRARIES ${LIBTRANSPORT_LIBRARIES}
- DEPENDS transport
- COMPONENT utils
+ DEPENDS ${LIBTRANSPORT}
+ COMPONENT hicn-utils
DEFINITIONS ${COMPILER_DEFINITIONS}
)
endforeach() \ No newline at end of file