summaryrefslogtreecommitdiffstats
path: root/common
diff options
context:
space:
mode:
authorMichal Cmarada <michal.cmarada@pantheon.tech>2018-09-25 11:15:35 +0200
committerMichal Cmarada <michal.cmarada@pantheon.tech>2018-09-25 11:22:18 +0200
commit556a0f59abc9b09005d40945bc20948d69e4f98e (patch)
tree76d795ae59aba49521fc4fdc7d65062c946147be /common
parent46bcceb927b1bce07c1c9517f45470703293eb84 (diff)
Bump ODL dependencies to Fluorine (HONEYCOMB-433)
Change-Id: I142ebd2899272feff00abe7d4bae708f093ee3ec Signed-off-by: Michal Cmarada <michal.cmarada@pantheon.tech>
Diffstat (limited to 'common')
-rw-r--r--common/api-parent/pom.xml9
-rw-r--r--common/honeycomb-parent/pom.xml22
-rw-r--r--common/impl-parent/pom.xml1
-rw-r--r--common/scripts-parent/pom.xml2
4 files changed, 25 insertions, 9 deletions
diff --git a/common/api-parent/pom.xml b/common/api-parent/pom.xml
index 0d41315..8fe25b3 100644
--- a/common/api-parent/pom.xml
+++ b/common/api-parent/pom.xml
@@ -28,6 +28,10 @@
<version>1.18.10-SNAPSHOT</version>
<packaging>pom</packaging>
+ <properties>
+ <annotations.version>3.0.0</annotations.version>
+ </properties>
+
<build>
<pluginManagement>
<plugins>
@@ -117,5 +121,10 @@
<groupId>org.opendaylight.yangtools</groupId>
<artifactId>yang-common</artifactId>
</dependency>
+ <dependency>
+ <groupId>com.google.code.findbugs</groupId>
+ <artifactId>annotations</artifactId>
+ <version>${annotations.version}</version>
+ </dependency>
</dependencies>
</project>
diff --git a/common/honeycomb-parent/pom.xml b/common/honeycomb-parent/pom.xml
index 9e5085d..4dc13ed 100644
--- a/common/honeycomb-parent/pom.xml
+++ b/common/honeycomb-parent/pom.xml
@@ -46,14 +46,14 @@
<project.reporting.outputEncoding>UTF-8</project.reporting.outputEncoding>
<!-- ODL dependencies -->
- <odl.yangtools.version>2.0.5</odl.yangtools.version>
- <odl.mdsal.version>2.4.3</odl.mdsal.version>
- <odl.mdsal.controller.version>1.7.3</odl.mdsal.controller.version>
- <odl.mdsalmodel.version>0.12.3</odl.mdsalmodel.version>
- <odl.netconf.version>1.4.3</odl.netconf.version>
- <odl.restconf.version>1.7.3</odl.restconf.version>
- <odl.salGenerator.version>0.12.3</odl.salGenerator.version>
- <odl.bgpcep.version>0.9.3</odl.bgpcep.version>
+ <odl.yangtools.version>2.0.11</odl.yangtools.version>
+ <odl.mdsal.version>2.5.0</odl.mdsal.version>
+ <odl.mdsal.controller.version>1.8.0</odl.mdsal.controller.version>
+ <odl.mdsalmodel.version>0.13.0</odl.mdsalmodel.version>
+ <odl.netconf.version>1.5.0</odl.netconf.version>
+ <odl.restconf.version>1.8.0</odl.restconf.version>
+ <odl.salGenerator.version>0.13.0</odl.salGenerator.version>
+ <odl.bgpcep.version>0.10.0</odl.bgpcep.version>
<salGeneratorPath>target/generated-sources/mdsal-binding</salGeneratorPath>
<!-- common dependencies -->
@@ -63,6 +63,7 @@
<guava.version>23.6-jre</guava.version>
<jsr305.version>3.0.0</jsr305.version>
<slf4j.version>1.7.21</slf4j.version>
+ <jdt.version>2.1.150</jdt.version>
<!-- plugins -->
<checkstyle.plugin.version>2.17</checkstyle.plugin.version>
@@ -196,6 +197,11 @@
<artifactId>slf4j-api</artifactId>
<version>${slf4j.version}</version>
</dependency>
+ <dependency>
+ <groupId>org.eclipse.jdt</groupId>
+ <artifactId>org.eclipse.jdt.annotation</artifactId>
+ <version>${jdt.version}</version>
+ </dependency>
<!-- Testing Dependencies -->
<dependency>
diff --git a/common/impl-parent/pom.xml b/common/impl-parent/pom.xml
index 8cdcedc..8f87d7a 100644
--- a/common/impl-parent/pom.xml
+++ b/common/impl-parent/pom.xml
@@ -34,6 +34,7 @@
<guice.config.version>1.2.0</guice.config.version>
<skinny.logback.version>1.0.8</skinny.logback.version>
<maven-resources-plugin.version>3.0.2</maven-resources-plugin.version>
+ <osgi-core.version>5.0.0</osgi-core.version>
</properties>
<dependencyManagement>
diff --git a/common/scripts-parent/pom.xml b/common/scripts-parent/pom.xml
index e4da7cb..61fe04a 100644
--- a/common/scripts-parent/pom.xml
+++ b/common/scripts-parent/pom.xml
@@ -32,7 +32,7 @@
<groovy.version>2.4.7</groovy.version>
<groovy.eclipse.compiler.version>2.9.2-01</groovy.eclipse.compiler.version>
<groovy.eclipse.batch.version>2.4.3-01</groovy.eclipse.batch.version>
- <odl.yang-binding.version>0.12.3</odl.yang-binding.version>
+ <odl.yang-binding.version>0.13.0</odl.yang-binding.version>
</properties>
<dependencyManagement>