aboutsummaryrefslogtreecommitdiffstats
path: root/nsh-plugin/configure.ac
diff options
context:
space:
mode:
authorKeith Burns (alagalah) <alagalah@gmail.com>2016-05-13 09:31:35 -0700
committerHÃ¥kan Jonsson <hakan.jonsson@ericsson.com>2016-06-15 06:18:31 +0000
commit1a8e2a697ff5513907a767a327d1e363b789f73a (patch)
treedecb5c2b57eb9618a99ee6926d423f3ef4565784 /nsh-plugin/configure.ac
parent08157b83782b7bedfd238c580cde5347ab5408a8 (diff)
NSHSFC-1 Initial move from VPP to NSH_SFC
- API is giving me some negative energy currently -- I'll work it out but wanted to publish both VPP-61 and this simultaneously Change-Id: I4a04b56dd470655114605621d0c44ea3c26bc069 Signed-off-by: Keith Burns (alagalah) <alagalah@gmail.com> Signed-off-by: Ed Warnicke <eaw@cisco.com>
Diffstat (limited to 'nsh-plugin/configure.ac')
-rw-r--r--nsh-plugin/configure.ac18
1 files changed, 18 insertions, 0 deletions
diff --git a/nsh-plugin/configure.ac b/nsh-plugin/configure.ac
new file mode 100644
index 0000000..46e8faf
--- /dev/null
+++ b/nsh-plugin/configure.ac
@@ -0,0 +1,18 @@
+
+AC_INIT(nsh_plugin, 1.0)
+AM_INIT_AUTOMAKE
+
+AC_PROG_LIBTOOL
+AM_PROG_AS
+AC_PROG_CC
+AM_PROG_CC_C_O
+
+AC_ARG_WITH(plugin-toolkit,
+ AC_HELP_STRING([--with-plugin-toolkit],
+ [build using the vpp toolkit]),
+ [with_plugin_toolkit=${prefix}/include],
+ [with_plugin_toolkit=.])
+
+AC_SUBST(TOOLKIT_INCLUDE,[${with_plugin_toolkit}])
+AM_CONDITIONAL(WITH_PLUGIN_TOOLKIT, test "$with_plugin_toolkit" != ".")
+AC_OUTPUT([Makefile])