aboutsummaryrefslogtreecommitdiffstats
path: root/nsh-plugin/java/Makefile.am
diff options
context:
space:
mode:
authorHongjun Ni <hongjun.ni@intel.com>2018-04-17 22:26:25 +0800
committerHongjun Ni <hongjun.ni@intel.com>2018-04-17 22:26:25 +0800
commit2fd1760193f985fb3db861fae21219b6a83d090c (patch)
treefc4dafecce35c26b206ead57d3700b03b882dc9d /nsh-plugin/java/Makefile.am
parenta0d8a8557fe7d405f45dda1bb844e7363bd677c8 (diff)
Fix compiling issue led by vppapigen rework
Change-Id: I2e7cc0f0302476e64f4aae328bc56e96cf6150b0 Signed-off-by: Hongjun Ni <hongjun.ni@intel.com>
Diffstat (limited to 'nsh-plugin/java/Makefile.am')
-rw-r--r--nsh-plugin/java/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/nsh-plugin/java/Makefile.am b/nsh-plugin/java/Makefile.am
index f85e163..c6aa0b6 100644
--- a/nsh-plugin/java/Makefile.am
+++ b/nsh-plugin/java/Makefile.am
@@ -63,6 +63,6 @@ $(jarfile_jnsh_sfc): libjvpp_nsh.la
nsh.api.json: $(api_file)
@echo " jNsh_sfc API"; \
$(CC) $(CPPFLAGS) -E -P -C -x c $^ \
- | vppapigen --input $(api_file) --json $@
+ | vppapigen --input $^ JSON --output $@
all-local: $(jarfile_jnsh_sfc)