aboutsummaryrefslogtreecommitdiffstats
path: root/vnet/Makefile.am
diff options
context:
space:
mode:
authorDave Barach <dave@barachs.net>2015-12-14 11:13:29 -0500
committerDave Barach <dave@barachs.net>2015-12-14 11:16:02 -0500
commit4e281a48e2afd258188c9ad996c46f166d4cfd9f (patch)
tree4abdf46defcf566c98ead3e075ce80e490a2da2e /vnet/Makefile.am
parentcd9752ce4f27dcad68ae085b519654ad5b10731a (diff)
Move rpc handler where it belongs, related cleanup
Change-Id: I393df100558a85fe676f4a4c8c9b546fa549ecc9 Signed-off-by: Dave Barach <dave@barachs.net>
Diffstat (limited to 'vnet/Makefile.am')
-rw-r--r--vnet/Makefile.am9
1 files changed, 1 insertions, 8 deletions
diff --git a/vnet/Makefile.am b/vnet/Makefile.am
index ee01bff1..1bde1e80 100644
--- a/vnet/Makefile.am
+++ b/vnet/Makefile.am
@@ -18,6 +18,7 @@ AM_CFLAGS = -Wall @DPDK@ @VIRL@
libvnet_la_SOURCES =
libvnetplugin_la_SOURCES =
nobase_include_HEADERS =
+noinst_PROGRAMS =
########################################
# Generic stuff
@@ -608,20 +609,12 @@ nobase_include_HEADERS += \
lib_LTLIBRARIES = libvnet.la libvnetplugin.la
-noinst_PROGRAMS = vnet_unix
-
-vnet_unix_SOURCES = \
- example/main_stub.c
-
-vnet_unix_LDFLAGS = -static
dpdk_libs =
if WITH_DPDK
dpdk_libs += -l:libdpdk.a
endif
-vnet_unix_LDADD = libvnet.la -l:libvlib_unix.a -l:libvlib.a -l:libvppinfra.a -lpthread -lvlibapi -lvlibmemory -lsvm -lm -ldl $(dpdk_libs) -lrt
-
pcap2pg_SOURCES = \
vnet/unix/pcap2pg.c \
vnet/unix/pcap.h