aboutsummaryrefslogtreecommitdiffstats
path: root/vpp/Makefile.am
diff options
context:
space:
mode:
authorDave Barach <dave@barachs.net>2016-10-31 11:59:07 -0400
committerOle Trøan <otroan@employees.org>2016-11-30 15:06:08 +0000
commitaff7077d2031545a15efd12e7f65eac723799491 (patch)
tree3a7b1c8b964d6b9008c6313f2751fd2d9506809f /vpp/Makefile.am
parent847944046c50cabd0d457d446d2c199a71abf049 (diff)
Start spliting vpe.api into logically related pieces
To reduce rebase / manual merge pain, among other things Change-Id: I3186df0479066916a2ca69c48759178b45ef035c Signed-off-by: Dave Barach <dave@barachs.net> Signed-off-by: Ole Troan <ot@cisco.com>
Diffstat (limited to 'vpp/Makefile.am')
-rw-r--r--vpp/Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/vpp/Makefile.am b/vpp/Makefile.am
index 214cc743..1c40ed3d 100644
--- a/vpp/Makefile.am
+++ b/vpp/Makefile.am
@@ -121,14 +121,13 @@ if WITH_IPV6SR
vpp_LDADD += -lcrypto
endif
+# Set the suffix list
SUFFIXES = .api.h .api
-%.api.h: %.api
- @echo " APIGEN " $@ ; \
- mkdir -p `dirname $@` ; \
- $(CC) $(CPPFLAGS) -E -P -C -x c $^ \
- | vppapigen --input - --output $@ --show-name $@
+# The actual %.api.h rule is in .../build-data/packages/suffix-rules.mk
+# and requires a symbolic link at the top of the vpp source tree
+include $(top_srcdir)/suffix-rules.mk
noinst_PROGRAMS += test_client