aboutsummaryrefslogtreecommitdiffstats
path: root/vpp/build-data/packages/plugins.mk
diff options
context:
space:
mode:
authorsreejith <sreejith.surendrannair@linaro.org>2017-03-29 01:15:02 -0400
committersreejith <sreejith.surendrannair@linaro.org>2017-03-29 02:23:59 -0400
commita23197980e40d4d9414bcfaf59005a1dc2a89251 (patch)
treeda3fc5410a9cda99e05d2e0f6dae06072a0c50b8 /vpp/build-data/packages/plugins.mk
parent746b57564deede624261ab8a96c94f562f24d22c (diff)
Added vpp intial source code from master branch 17.01.1
Change-Id: I81bdace6f330825a1746a853766779dfb24765fd Signed-off-by: sreejith <sreejith.surendrannair@linaro.org>
Diffstat (limited to 'vpp/build-data/packages/plugins.mk')
-rw-r--r--vpp/build-data/packages/plugins.mk45
1 files changed, 45 insertions, 0 deletions
diff --git a/vpp/build-data/packages/plugins.mk b/vpp/build-data/packages/plugins.mk
new file mode 100644
index 00000000..44a8e2bd
--- /dev/null
+++ b/vpp/build-data/packages/plugins.mk
@@ -0,0 +1,45 @@
+plugins_configure_depend = \
+ vppinfra-install \
+ vlib-api-install \
+ vpp-api-test-install \
+ vnet-install \
+ vlib-install \
+ vpp-api-install
+
+plugins_CPPFLAGS = $(call installed_includes_fn, \
+ vppinfra \
+ vlib \
+ vnet \
+ svm \
+ vpp-api-test \
+ vlib-api \
+ vpp-api)
+
+plugins_LDFLAGS = $(call installed_libs_fn, \
+ vppinfra \
+ vlib \
+ vlib-api)
+
+ifeq ($($(PLATFORM)_enable_tests),yes)
+plugins_configure_args += --enable-tests
+endif
+
+# Platform dependent configure flags
+plugins_configure_args += $(plugins_configure_args_$(PLATFORM))
+
+# include & link with openssl only if needed
+ifneq ($($(PLATFORM)_uses_openssl),no)
+plugins_CPPFLAGS += $(call installed_includes_fn, openssl)
+plugins_LDFLAGS += $(call installed_libs_fn, openssl)
+endif
+
+ifneq ($($(PLATFORM)_uses_dpdk),no)
+ifeq ($($(PLATFORM)_uses_external_dpdk),yes)
+plugins_CPPFLAGS += -I$($(PLATFORM)_dpdk_inc_dir)
+plugins_LDFLAGS += -L$($(PLATFORM)_dpdk_lib_dir)
+else
+plugins_configure_depend += dpdk-install
+plugins_CPPFLAGS += $(call installed_includes_fn, dpdk)
+plugins_LDFLAGS += $(call installed_libs_fn, dpdk)
+endif
+endif