aboutsummaryrefslogtreecommitdiffstats
path: root/vpp/vpp-api-test/Makefile.am
diff options
context:
space:
mode:
authorsreejith <sreejith.surendrannair@linaro.org>2017-03-29 01:15:02 -0400
committersreejith <sreejith.surendrannair@linaro.org>2017-03-29 02:23:59 -0400
commita23197980e40d4d9414bcfaf59005a1dc2a89251 (patch)
treeda3fc5410a9cda99e05d2e0f6dae06072a0c50b8 /vpp/vpp-api-test/Makefile.am
parent746b57564deede624261ab8a96c94f562f24d22c (diff)
Added vpp intial source code from master branch 17.01.1
Change-Id: I81bdace6f330825a1746a853766779dfb24765fd Signed-off-by: sreejith <sreejith.surendrannair@linaro.org>
Diffstat (limited to 'vpp/vpp-api-test/Makefile.am')
-rw-r--r--vpp/vpp-api-test/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/vpp/vpp-api-test/Makefile.am b/vpp/vpp-api-test/Makefile.am
new file mode 100644
index 00000000..27466fad
--- /dev/null
+++ b/vpp/vpp-api-test/Makefile.am
@@ -0,0 +1,37 @@
+# Copyright (c) 2015 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+AUTOMAKE_OPTIONS = foreign subdir-objects
+
+AM_CFLAGS = -Wall @Q_PLATFORM_DEFINE@ @Q_PLATFORM_PLUGPATH@ @DPDK@ @DPDK_CRYPTO@
+
+libvatplugin_la_SOURCES = \
+ vat/plugin_api.c
+
+lib_LTLIBRARIES = libvatplugin.la
+
+bin_PROGRAMS = vpp_api_test vpp_json_test vpp_restart
+
+vpp_api_test_SOURCES = vat/api_format.c vat/main.c vat/plugin.c vat/vat.h vat/json_format.h vat/json_format.c
+vpp_json_test_SOURCES = vat/json_format.h vat/json_format.c vat/json_test.c
+
+vpp_api_test_LDADD = -lvlibmemoryclient -lvlibapi -lsvm \
+ -lvppinfra -lpthread -lm \
+ -lrt -ldl libvatplugin.la
+vpp_json_test_LDADD = -lvppinfra -lm
+nobase_include_HEADERS = vat/vat.h vat/json_format.h
+
+vpp_restart_SOURCES = vat/restart.c
+vpp_restart_LDADD = -lsvmdb -lsvm -lvppinfra -lpthread -lrt
+
+dist_bin_SCRIPTS = scripts/vppctl