aboutsummaryrefslogtreecommitdiffstats
path: root/vpp/vpp/Makefile.am
diff options
context:
space:
mode:
authorsrsurend <srsurend@cisco.com>2017-04-23 12:38:20 -0400
committersrsurend <srsurend@cisco.com>2017-05-22 07:04:56 -0400
commitbc253c90c5d13d14b658829cb1159c0467332a8f (patch)
tree00d36195d7e2180de5bf81e63eece0a8bfe09929 /vpp/vpp/Makefile.am
parenta23197980e40d4d9414bcfaf59005a1dc2a89251 (diff)
Added initial changes for odp support with vpp.HEADmaster
Change-Id: Ieb5c099c360cddd6f6b784da2838d543ceb1cb92 Signed-off-by: srsurend <srsurend@cisco.com> Signed-off-by: sachin saxena <sachin.saxena@nxp.com>
Diffstat (limited to 'vpp/vpp/Makefile.am')
-rw-r--r--vpp/vpp/Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/vpp/vpp/Makefile.am b/vpp/vpp/Makefile.am
index 9ae06055..2d0c2bb9 100644
--- a/vpp/vpp/Makefile.am
+++ b/vpp/vpp/Makefile.am
@@ -100,6 +100,12 @@ vpp_LDADD += -lvnet
vpp_LDADD += -lsvm -lsvmdb -lrt
+if WITH_ODPLIB
+vpp_LDFLAGS = -Wl,--whole-archive
+vpp_LDADD += $(ODP_LIBS)
+vpp_LDFLAGS += -Wl,--no-whole-archive
+endif
+
vpp_LDADD += -lvnetplugin
if WITH_DPDK