aboutsummaryrefslogtreecommitdiffstats
path: root/vpp/vppapigen/Makefile.am
diff options
context:
space:
mode:
authorsreejith <sreejith.surendrannair@linaro.org>2017-03-29 01:15:02 -0400
committersreejith <sreejith.surendrannair@linaro.org>2017-03-29 02:23:59 -0400
commita23197980e40d4d9414bcfaf59005a1dc2a89251 (patch)
treeda3fc5410a9cda99e05d2e0f6dae06072a0c50b8 /vpp/vppapigen/Makefile.am
parent746b57564deede624261ab8a96c94f562f24d22c (diff)
Added vpp intial source code from master branch 17.01.1
Change-Id: I81bdace6f330825a1746a853766779dfb24765fd Signed-off-by: sreejith <sreejith.surendrannair@linaro.org>
Diffstat (limited to 'vpp/vppapigen/Makefile.am')
-rw-r--r--vpp/vppapigen/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/vpp/vppapigen/Makefile.am b/vpp/vppapigen/Makefile.am
new file mode 100644
index 00000000..16a48736
--- /dev/null
+++ b/vpp/vppapigen/Makefile.am
@@ -0,0 +1,29 @@
+# Copyright (c) 2015 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+AUTOMAKE_OPTIONS = foreign
+
+bin_PROGRAMS = vppapigen
+bin_SCRIPTS =
+
+BUILT_SOURCES = gram.h
+
+gram.h: gram.y
+ $(YACC) -d @srcdir@/gram.y
+ mv y.tab.h gram.h
+ rm y.tab.c
+
+vppapigen_SOURCES = gram.y lex.c node.c
+vppapigen_CPPFLAGS =
+vppapigen_LDADD = -lvppinfra
+vppapigen_LDFLAGS = -static