aboutsummaryrefslogtreecommitdiffstats
path: root/vpp/vppinfra/configure.ac
diff options
context:
space:
mode:
authorsreejith <sreejith.surendrannair@linaro.org>2017-03-29 01:15:02 -0400
committersreejith <sreejith.surendrannair@linaro.org>2017-03-29 02:23:59 -0400
commita23197980e40d4d9414bcfaf59005a1dc2a89251 (patch)
treeda3fc5410a9cda99e05d2e0f6dae06072a0c50b8 /vpp/vppinfra/configure.ac
parent746b57564deede624261ab8a96c94f562f24d22c (diff)
Added vpp intial source code from master branch 17.01.1
Change-Id: I81bdace6f330825a1746a853766779dfb24765fd Signed-off-by: sreejith <sreejith.surendrannair@linaro.org>
Diffstat (limited to 'vpp/vppinfra/configure.ac')
-rw-r--r--vpp/vppinfra/configure.ac52
1 files changed, 52 insertions, 0 deletions
diff --git a/vpp/vppinfra/configure.ac b/vpp/vppinfra/configure.ac
new file mode 100644
index 00000000..88939383
--- /dev/null
+++ b/vpp/vppinfra/configure.ac
@@ -0,0 +1,52 @@
+# Process this file with autoconf to produce a configure script.
+AC_INIT(libvppinfra,1.0,)
+AC_CONFIG_AUX_DIR(config)
+AC_CONFIG_HEADERS(config/config.h)
+AC_CANONICAL_BUILD
+AC_CANONICAL_HOST
+AM_INIT_AUTOMAKE([gnu no-dist-gzip dist-bzip2])
+AM_SILENT_RULES([yes])
+
+# Checks for programs.
+AC_PROG_CC
+AM_PROG_AS
+AM_PROG_LIBTOOL
+
+######################################################################
+
+dnl ------------
+dnl Check CFLAGS, CC
+dnl ------------
+AC_ARG_WITH(cc,
+ AC_HELP_STRING([--with-cc],[Set CC for use as C compiler.]),
+ [CC="$with_cc"])
+
+AC_ARG_WITH(cflags,
+ AC_HELP_STRING([--with-cflags],[Set CFLAGS for use by C compiler.]),
+ [CFLAGS="$with_cflags"])
+
+AC_ARG_WITH(ldflags,
+ AC_HELP_STRING([--with-ldflags],[Set LDFLAGS for linking.]),
+ [LDFLAGS="$with_ldflags"])
+
+######################################################################
+
+AC_ARG_ENABLE(tests,
+ AC_HELP_STRING([--enable-tests],[Enable unit tests]),
+ [enable_tests=1],
+ [enable_tests=0])
+
+AM_CONDITIONAL(ENABLE_TESTS, test "$enable_tests" = "1")
+
+AC_ARG_WITH(unix,
+ AC_HELP_STRING([--with-unix],[Compile unix version of clib]),
+ [],
+ [case $host_os in
+ darwin* | linux*) with_unix=yes;;
+ *) with_unix=no;;
+ esac])
+
+AM_CONDITIONAL(WITH_UNIX, test "$with_unix" = "yes")
+
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT