aboutsummaryrefslogtreecommitdiffstats
path: root/src/vpp-api/python/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/vpp-api/python/Makefile.am')
-rw-r--r--src/vpp-api/python/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/vpp-api/python/Makefile.am b/src/vpp-api/python/Makefile.am
new file mode 100644
index 00000000..e6c064e1
--- /dev/null
+++ b/src/vpp-api/python/Makefile.am
@@ -0,0 +1,23 @@
+# Copyright (c) 2016 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+install-exec-local:
+ (cd $(srcdir) ; $(PYTHON) $(srcdir)/setup.py build \
+ --build-base $(shell readlink -f $(builddir))/build \
+ install \
+ --root / \
+ --prefix $(DESTDIR)$(prefix) \
+ --single-version-externally-managed \
+ --verbose \
+ bdist_egg \
+ --dist-dir=$(DESTDIR)$(prefix))