aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/CMakeLists.txt
diff options
context:
space:
mode:
authorHongjun Ni <hongjun.ni@intel.com>2018-12-18 05:27:01 +0000
committerGerrit Code Review <gerrit@fd.io>2018-12-18 05:27:01 +0000
commit9c702c398034d38a9e3e81600b676e371dc66268 (patch)
treef1ba92dec86d80b14571c44c8212531007c8fa8d /src/plugins/CMakeLists.txt
parenta9a66368a5974bc38025b05073bf49493c8801e1 (diff)
parent14243005c70d47fadc918031b24747e6c417d7f5 (diff)
Merge "Binary-api wrappers: IP and interfaces"
Diffstat (limited to 'src/plugins/CMakeLists.txt')
-rw-r--r--src/plugins/CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/plugins/CMakeLists.txt b/src/plugins/CMakeLists.txt
index 840a890..8f248c5 100644
--- a/src/plugins/CMakeLists.txt
+++ b/src/plugins/CMakeLists.txt
@@ -31,6 +31,15 @@ if (NOT SR_PLUGINS_DIR)
message(FATAL_ERROR "Cannot get sysrepo plugins directory due to missing pkg-config, set SR_PLUGINS_DIR manually.")
endif()
+set(BAPI_SRC
+ ./bapi/bapi.c
+ ./bapi/bapi_interface.c
+ ./bapi/bapi_ip.c
+ )
+add_library(bapi SHARED ${BAPI_SRC})
+target_include_directories(bapi PUBLIC ${VPP_INCLUDE_DIRS} ./bapi)
+target_link_libraries(bapi ${VPP_LIBRARIES})
+
# plugins sources
set(PLUGINS_SOURCES
sc_interface.c
@@ -44,7 +53,7 @@ set(PLUGINS_SOURCES
# build the source code into shared library
add_library(vpp-plugins SHARED ${PLUGINS_SOURCES})
-target_link_libraries(vpp-plugins ${SYSREPO_LIBRARIES} ${SCVPP_LIBRARIES})
+target_link_libraries(vpp-plugins ${SYSREPO_LIBRARIES} ${SCVPP_LIBRARIES} bapi)
# install the plugin into plugins dir
install(TARGETS vpp-plugins DESTINATION ${SR_PLUGINS_DIR})