aboutsummaryrefslogtreecommitdiffstats
path: root/src/plugins/CMakeLists.txt
diff options
context:
space:
mode:
authorJunfeng Wang <Drenfong.Wang@intel.com>2019-04-18 01:16:15 +0000
committerJunfeng Wang <Drenfong.Wang@intel.com>2019-04-18 02:09:49 +0000
commitaf67922d18631a33fca11a66a527407948051e18 (patch)
treebc0c50356d79405924abc287469d38b96132eb67 /src/plugins/CMakeLists.txt
parent124193a900f81146936918d1ec90a7bde64420a2 (diff)
when "make build-package", we need to "make build-scvpp" first, because we use
pkgconfig to find dependence(libscvpp.so). this patch will compile libscvpp.so when compile plugin,you needn't extra step. Change-Id: I9dcd733ec3535a8fa5310f75ae141712320affa5 Signed-off-by: Junfeng Wang <Drenfong.Wang@intel.com>
Diffstat (limited to 'src/plugins/CMakeLists.txt')
-rw-r--r--src/plugins/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/plugins/CMakeLists.txt b/src/plugins/CMakeLists.txt
index d7f38e0..a07ae60 100644
--- a/src/plugins/CMakeLists.txt
+++ b/src/plugins/CMakeLists.txt
@@ -25,7 +25,9 @@ list(APPEND CMAKE_MODULE_PATH "${CMAKE_CURRENT_LIST_DIR}/../cmake")
find_package(VPP) #use FindVPP.cmake
find_package(PkgConfig) #official cmake module
pkg_check_modules(SYSREPO REQUIRED libsysrepo) #PkgConfig cmake module maccro
-pkg_check_modules(SCVPP REQUIRED libscvpp) #PkgConfig cmake module maccro
+
+add_subdirectory(${CMAKE_CURRENT_LIST_DIR}/../scvpp scvpp_out)
+include_directories(${CMAKE_CURRENT_LIST_DIR}/../scvpp/inc)
# get sysrepo plugins directory from pkgconfig
if (NOT SR_PLUGINS_DIR)
@@ -63,7 +65,7 @@ set(PLUGINS_SOURCES
# build the source code into shared library
add_library(vpp-plugins SHARED ${PLUGINS_SOURCES})
-target_link_libraries(vpp-plugins ${SYSREPO_LIBRARIES} ${SCVPP_LIBRARIES})
+target_link_libraries(vpp-plugins ${SYSREPO_LIBRARIES} scvpp)
# INSTALL
#########