summaryrefslogtreecommitdiffstats
path: root/external_libs/yaml-cpp/test/CMakeLists.txt
diff options
context:
space:
mode:
authorDan Klein <danklei@cisco.com>2015-08-26 15:05:58 +0300
committerDan Klein <danklei@cisco.com>2015-08-26 15:05:58 +0300
commitfc46f2618332037a8c1b58fbce5d616033bff1c9 (patch)
treebdb7ffdb92732438d540ef06622e570a3c60a8f4 /external_libs/yaml-cpp/test/CMakeLists.txt
parentcecaf28ab61882d323cb5f3d813518523f7e836b (diff)
Rearranged files and external libraries in two different locations, one for cpp (trex-core/external_libs) and one for python (trex-core/scripts/external_libs)
Diffstat (limited to 'external_libs/yaml-cpp/test/CMakeLists.txt')
-rw-r--r--external_libs/yaml-cpp/test/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/external_libs/yaml-cpp/test/CMakeLists.txt b/external_libs/yaml-cpp/test/CMakeLists.txt
new file mode 100644
index 00000000..241c19ef
--- /dev/null
+++ b/external_libs/yaml-cpp/test/CMakeLists.txt
@@ -0,0 +1,15 @@
+file(GLOB test_headers [a-z]*.h)
+file(GLOB test_sources [a-z]*.cpp)
+file(GLOB test_old_api_sources old-api/[a-z]*.cpp)
+
+list(APPEND test_sources ${test_old_api_sources})
+
+include_directories(${YAML_CPP_SOURCE_DIR}/test)
+
+add_executable(run-tests
+ ${test_sources}
+ ${test_headers}
+)
+target_link_libraries(run-tests yaml-cpp)
+
+add_test(yaml-reader-test run-tests)