summaryrefslogtreecommitdiffstats
path: root/scripts/external_libs/dpkt-1.8.6/setup.py
diff options
context:
space:
mode:
authorimarom <imarom@cisco.com>2015-09-21 18:55:15 +0300
committerimarom <imarom@cisco.com>2015-09-21 18:55:15 +0300
commit14006b519bfd679227a87d0e6a2be9726774aafc (patch)
tree88b8eed17c52d3460291248cfd807a19c592ea3b /scripts/external_libs/dpkt-1.8.6/setup.py
parentd9e1cc14540431aa8baf8480625aa54c2a7c7175 (diff)
parentdbeb7ecc059bb78db54ec285a4216a661bbedd23 (diff)
Merge branch 'master' into rpc
Conflicts: scripts/automation/trex_control_plane/client_utils/jsonrpc_client.py
Diffstat (limited to 'scripts/external_libs/dpkt-1.8.6/setup.py')
-rw-r--r--scripts/external_libs/dpkt-1.8.6/setup.py40
1 files changed, 40 insertions, 0 deletions
diff --git a/scripts/external_libs/dpkt-1.8.6/setup.py b/scripts/external_libs/dpkt-1.8.6/setup.py
new file mode 100644
index 00000000..fe4f84fa
--- /dev/null
+++ b/scripts/external_libs/dpkt-1.8.6/setup.py
@@ -0,0 +1,40 @@
+import os
+import sys
+
+try:
+ from setuptools import setup, Command
+except ImportError:
+ from distutils.core import setup, Command
+
+package_name = 'dpkt'
+description = 'fast, simple packet creation / parsing, with definitions for the basic TCP/IP protocols'
+readme = open('README.rst').read()
+requirements = [ ]
+
+# PyPI Readme
+long_description = open('README.rst').read()
+
+# Pull in the package
+package = __import__(package_name)
+
+setup(name=package_name,
+ version=package.__version__,
+ author=package.__author__,
+ url=package.__url__,
+ description=description,
+ long_description=long_description,
+ packages=['dpkt'],
+ install_requires=requirements,
+ license='BSD',
+ zip_safe=False,
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: BSD License',
+ 'Natural Language :: English',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: Implementation :: CPython',
+ 'Programming Language :: Python :: Implementation :: PyPy',
+ ]
+)