summaryrefslogtreecommitdiffstats
path: root/scripts/external_libs/dpkt-1.8.6/setup.py
diff options
context:
space:
mode:
authorimarom <imarom@cisco.com>2016-03-22 17:20:13 +0200
committerimarom <imarom@cisco.com>2016-03-23 13:01:06 +0200
commit46f110d0c728ba9299156cf92a59c27c2d0348fa (patch)
tree9053af8b721a79378cea8ee4401d029b5a23d4b6 /scripts/external_libs/dpkt-1.8.6/setup.py
parent9c03844bea5c9fc4423ed4c6ddf9376a9cdd7ac5 (diff)
removed dpkt
Diffstat (limited to 'scripts/external_libs/dpkt-1.8.6/setup.py')
-rw-r--r--scripts/external_libs/dpkt-1.8.6/setup.py40
1 files changed, 0 insertions, 40 deletions
diff --git a/scripts/external_libs/dpkt-1.8.6/setup.py b/scripts/external_libs/dpkt-1.8.6/setup.py
deleted file mode 100644
index fe4f84fa..00000000
--- a/scripts/external_libs/dpkt-1.8.6/setup.py
+++ /dev/null
@@ -1,40 +0,0 @@
-import os
-import sys
-
-try:
- from setuptools import setup, Command
-except ImportError:
- from distutils.core import setup, Command
-
-package_name = 'dpkt'
-description = 'fast, simple packet creation / parsing, with definitions for the basic TCP/IP protocols'
-readme = open('README.rst').read()
-requirements = [ ]
-
-# PyPI Readme
-long_description = open('README.rst').read()
-
-# Pull in the package
-package = __import__(package_name)
-
-setup(name=package_name,
- version=package.__version__,
- author=package.__author__,
- url=package.__url__,
- description=description,
- long_description=long_description,
- packages=['dpkt'],
- install_requires=requirements,
- license='BSD',
- zip_safe=False,
- classifiers=[
- 'Development Status :: 4 - Beta',
- 'Intended Audience :: Developers',
- 'License :: OSI Approved :: BSD License',
- 'Natural Language :: English',
- 'Programming Language :: Python :: 2.6',
- 'Programming Language :: Python :: 2.7',
- 'Programming Language :: Python :: Implementation :: CPython',
- 'Programming Language :: Python :: Implementation :: PyPy',
- ]
-)