summaryrefslogtreecommitdiffstats
path: root/build-data/packages/external.mk
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2018-09-18 18:41:38 +0200
committerDamjan Marion <damarion@cisco.com>2018-09-20 14:30:54 +0200
commit4a6cb83d334e391f85332ea38a2e467ac7743e4b (patch)
tree7d667a9d07c33e1a948f73892169f61da595ca4f /build-data/packages/external.mk
parent9c0a3c423ee0b9326f600a00c1bd46fef45d4975 (diff)
rename vpp-dpdk-dev to vpp-ext-deps
We need to have new tenants in the development package. This is first of series of patches which will allow us to have multiple external libs and tools packaged for developer's convenience. Change-Id: I884bd75fba96005bbf8cea92774682b2228e0e22 Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'build-data/packages/external.mk')
-rw-r--r--build-data/packages/external.mk51
1 files changed, 51 insertions, 0 deletions
diff --git a/build-data/packages/external.mk b/build-data/packages/external.mk
new file mode 100644
index 00000000000..07daac09849
--- /dev/null
+++ b/build-data/packages/external.mk
@@ -0,0 +1,51 @@
+# Copyright (c) 2015 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+external_source = build
+
+ifneq (,$(findstring debug,$(TAG)))
+ DPDK_DEBUG=y
+else
+ DPDK_DEBUG=n
+endif
+
+DPDK_MAKE_ARGS = -C $(call find_source_fn,$(PACKAGE_SOURCE)) \
+ DPDK_BUILD_DIR=$(PACKAGE_BUILD_DIR) \
+ DPDK_INSTALL_DIR=$(PACKAGE_INSTALL_DIR) \
+ DPDK_DEBUG=$(DPDK_DEBUG)
+
+DPDK_MLX5_PMD=$(strip $($(PLATFORM)_uses_dpdk_mlx5_pmd))
+ifneq ($(DPDK_MLX5_PMD),)
+DPDK_MAKE_ARGS += DPDK_MLX5_PMD=y
+endif
+
+DPDK_MLX4_PMD=$(strip $($(PLATFORM)_uses_dpdk_mlx4_pmd))
+ifneq ($(DPDK_MLX4_PMD),)
+DPDK_MAKE_ARGS += DPDK_MLX4_PMD=y
+endif
+
+DPDK_PLATFORM_TARGET=$(strip $($(PLATFORM)_dpdk_target))
+ifneq ($(DPDK_PLATFORM_TARGET),)
+DPDK_MAKE_ARGS += DPDK_TARGET=$(DPDK_PLATFORM_TARGET)
+endif
+
+DPDK_MAKE_EXTRA_ARGS = $(strip $($(PLATFORM)_dpdk_make_extra_args))
+ifneq ($(DPDK_MAKE_EXTRA_ARGS),)
+DPDK_MAKE_ARGS += DPDK_MAKE_EXTRA_ARGS="$(DPDK_MAKE_EXTRA_ARGS)"
+endif
+
+external_configure = echo
+
+external_make_args = $(DPDK_MAKE_ARGS) -C external ebuild-build
+
+external_install = make $(DPDK_MAKE_ARGS) -C external ebuild-install