summaryrefslogtreecommitdiffstats
path: root/build/external/packages/nasm.mk
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2018-09-21 12:27:45 +0200
committerFlorin Coras <florin.coras@gmail.com>2018-09-21 17:51:25 +0000
commit561f2730e8b137cd4e7132b05dab49f6e768ae23 (patch)
tree102d8db51c4d9ea5ecd7d355cdf9fdeb12394539 /build/external/packages/nasm.mk
parentd974cd4262238168db65b9d837066f7c7511a9c5 (diff)
add: nasm and ipsec-mb into vpp-ext-deps packaging
Change-Id: Ie5d85af84ae0d8b15edf5962213ed1b1953bee2f Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'build/external/packages/nasm.mk')
-rw-r--r--build/external/packages/nasm.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/build/external/packages/nasm.mk b/build/external/packages/nasm.mk
new file mode 100644
index 00000000000..1219b3310af
--- /dev/null
+++ b/build/external/packages/nasm.mk
@@ -0,0 +1,21 @@
+# Copyright (c) 2018 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+nasm_version := 2.13.03
+nasm_tarball := nasm-$(nasm_version).tar.xz
+nasm_tarball_md5sum := d5ca2ad7121ccbae69dd606b1038532c
+nasm_tarball_strip_dirs := 1
+nasm_url := http://www.nasm.us/pub/nasm/releasebuilds/$(nasm_version)/$(nasm_tarball)
+nasm_cflags := -Wno-implicit-fallthrough -std=c11
+
+$(eval $(call package,nasm))