summaryrefslogtreecommitdiffstats
path: root/dpdk/deb/debian/rules
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2018-09-18 18:41:38 +0200
committerDamjan Marion <damarion@cisco.com>2018-09-20 14:30:54 +0200
commit4a6cb83d334e391f85332ea38a2e467ac7743e4b (patch)
tree7d667a9d07c33e1a948f73892169f61da595ca4f /dpdk/deb/debian/rules
parent9c0a3c423ee0b9326f600a00c1bd46fef45d4975 (diff)
rename vpp-dpdk-dev to vpp-ext-deps
We need to have new tenants in the development package. This is first of series of patches which will allow us to have multiple external libs and tools packaged for developer's convenience. Change-Id: I884bd75fba96005bbf8cea92774682b2228e0e22 Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'dpdk/deb/debian/rules')
-rwxr-xr-xdpdk/deb/debian/rules40
1 files changed, 0 insertions, 40 deletions
diff --git a/dpdk/deb/debian/rules b/dpdk/deb/debian/rules
deleted file mode 100755
index 7ef6ba1518e..00000000000
--- a/dpdk/deb/debian/rules
+++ /dev/null
@@ -1,40 +0,0 @@
-#!/usr/bin/make -f
-DH_VERBOSE = 1
-PKG=vpp-dpdk
-
-VERSION = $(shell dpkg-parsechangelog | sed -nr '/^Version:/s/Version: //p')
-BASE_VER = $(word 1, $(subst -, ,$(VERSION)))
-
-export DPDK_BUILD_DIR=$(CURDIR)/_build
-export DPDK_INSTALL_DIR=$(CURDIR)/debian/tmp/usr
-
-SRC=$(wildcard _build/dpdk*$(BASE_VER))
-
-MAKE_ARGS=-C ..
-
-include /usr/share/dpkg/default.mk
-
-%:
- dh $@ --with dkms
-
-override_dh_clean:
- make $(MAKE_ARGS) clean
-
-override_dh_auto_configure:
- make $(MAKE_ARGS) config
-
-override_dh_install:
- make $(MAKE_ARGS) install
- dh_install -p$(PKG)-dkms \
- $(SRC)/lib/librte_eal/common/include/rte_pci_dev_feature_defs.h \
- $(SRC)/lib/librte_eal/common/include/rte_pci_dev_features.h \
- $(wildcard $(SRC)/*/*/*/igb_uio/igb_uio.c) \
- $(wildcard $(SRC)/*/*/*/igb_uio/compat.h) \
- $(wildcard $(SRC)/*/*/igb_uio/igb_uio.c) \
- $(wildcard $(SRC)/*/*/igb_uio/compat.h) \
- debian/dkms/Makefile \
- /usr/src/$(PKG)-dkms-$(VERSION)
- dh_install -p$(PKG)-dev --autodest /usr
-
-override_dh_dkms:
- dh_dkms -p$(PKG)-dkms -V $(VERSION)