summaryrefslogtreecommitdiffstats
path: root/extras/deprecated/elftool/CMakeLists.txt
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2020-05-07 09:49:27 +0200
committerFlorin Coras <florin.coras@gmail.com>2020-05-07 16:47:33 +0000
commit5505ee8904fafc7c1f017f88853f80a616784cf2 (patch)
tree6d72986511428f33236dd950559b0f3618d8ac19 /extras/deprecated/elftool/CMakeLists.txt
parent72db664c76fe3e4fb23020b9a191017c4ea4cb69 (diff)
misc: deprecate elftool
Type: make Change-Id: I34fec1c40ef660177c266517eaf41d60827609f4 Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'extras/deprecated/elftool/CMakeLists.txt')
-rw-r--r--extras/deprecated/elftool/CMakeLists.txt17
1 files changed, 17 insertions, 0 deletions
diff --git a/extras/deprecated/elftool/CMakeLists.txt b/extras/deprecated/elftool/CMakeLists.txt
new file mode 100644
index 00000000000..d85c2b56c59
--- /dev/null
+++ b/extras/deprecated/elftool/CMakeLists.txt
@@ -0,0 +1,17 @@
+# Copyright (c) 2018 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+add_vpp_executable(elftool
+ SOURCES elftool.c
+ LINK_LIBRARIES vppinfra
+)