summaryrefslogtreecommitdiffstats
path: root/extras/deprecated/vom/CMakeLists.txt
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2020-10-16 15:28:47 +0200
committerDamjan Marion <damarion@cisco.com>2020-10-16 15:33:18 +0200
commit8c1afb56b6a479d6595444238815c4ced0e754ea (patch)
tree115e0d7685cf24f3a77549e5bc1ce151a09cec75 /extras/deprecated/vom/CMakeLists.txt
parentfbe4e36b9924c135410e1d52c959d0c3629be12b (diff)
misc: deprecate VOM
Type: make Change-Id: Ifb3e52af93d24fcc2f2e6a0c408e16902a2fe553 Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'extras/deprecated/vom/CMakeLists.txt')
-rw-r--r--extras/deprecated/vom/CMakeLists.txt46
1 files changed, 46 insertions, 0 deletions
diff --git a/extras/deprecated/vom/CMakeLists.txt b/extras/deprecated/vom/CMakeLists.txt
new file mode 100644
index 00000000000..4947235717e
--- /dev/null
+++ b/extras/deprecated/vom/CMakeLists.txt
@@ -0,0 +1,46 @@
+# Copyright (c) 2018 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+cmake_minimum_required(VERSION 3.5 FATAL_ERROR)
+
+project(vom)
+
+include(CheckCCompilerFlag)
+include(CheckCXXCompilerFlag)
+
+unset (VOM_LIB_VERSION)
+execute_process(
+ WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
+ COMMAND bash -c "git describe | cut -f1 -d- | cut -dv -f2"
+ OUTPUT_VARIABLE VOM_LIB_VERSION
+ OUTPUT_STRIP_TRAILING_WHITESPACE
+)
+
+set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
+set(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -g")
+set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/lib)
+set(CMAKE_INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
+set(CMAKE_INSTALL_MESSAGE NEVER)
+
+find_package(VPP)
+find_package(Threads REQUIRED)
+find_package(Boost OPTIONAL_COMPONENTS system filesystem)
+
+add_subdirectory(vom)
+add_subdirectory(cmake)
+
+add_vpp_packaging(
+ NAME "vom"
+ VENDOR "fd.io"
+ DESCRIPTION "VPP Object Model"
+)