summaryrefslogtreecommitdiffstats
path: root/extras/gmod/Makefile.am
diff options
context:
space:
mode:
authorDamjan Marion <damarion@cisco.com>2020-10-17 11:53:31 +0200
committerDamjan Marion <damarion@cisco.com>2020-10-17 11:53:31 +0200
commitada5bbf3303e8fb6f53ff39e6074ae820457224d (patch)
tree766e2535df3eef2e2707ca9cf112a71b9d69dc31 /extras/gmod/Makefile.am
parent03b76a20c569b8275beb8783691300a7d66b54a4 (diff)
misc: move gmod to extras/
Type: make Change-Id: I057237ec5cef4dbecf6b6cd5a0adb4b7dfa78337 Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'extras/gmod/Makefile.am')
-rw-r--r--extras/gmod/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/extras/gmod/Makefile.am b/extras/gmod/Makefile.am
new file mode 100644
index 00000000000..643e170df98
--- /dev/null
+++ b/extras/gmod/Makefile.am
@@ -0,0 +1,27 @@
+# Copyright (c) 2015 Cisco and/or its affiliates.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+AUTOMAKE_OPTIONS = foreign subdir-objects
+
+AM_CFLAGS = -Wall
+
+lib_LTLIBRARIES = libgmodvpp.la
+
+libgmodvpp_la_SOURCES = gmod/mod_vpp.c
+
+libgmodvpp_la_LDFLAGS = -module -avoid-version
+
+libgmodvpp_la_LIBADD = -lsvm -lsvmdb -lvppinfra -lapr-1
+
+gconfdir = $(prefix)/etc/conf.d
+gconf_DATA = gmod/vpp.conf