aboutsummaryrefslogtreecommitdiffstats
path: root/extras/japi/CMakeLists.txt
diff options
context:
space:
mode:
authorDamjan Marion <dmarion@me.com>2018-09-27 18:02:28 +0000
committerFlorin Coras <florin.coras@gmail.com>2018-09-27 20:00:43 +0000
commit09cce66888f622af285e92ae05f76462a5a6d3b5 (patch)
tree61c0c1629d4d53e336594f35d86ce5e6369c4940 /extras/japi/CMakeLists.txt
parent430420fbbade8a45671cac5ab8f3ba7a70fe4434 (diff)
Revert "japi: Move Java API binding to cmake"
components: Development CMake Error at /usr/share/cmake-3.10/Modules/FindPackageHandleStandardArgs.cmake:137 (message): Could NOT find JNI (missing: JAVA_AWT_INCLUDE_PATH) Call Stack (most recent call first): /usr/share/cmake-3.10/Modules/FindPackageHandleStandardArgs.cmake:378 (_FPHSA_FAILURE_MESSAGE) /usr/share/cmake-3.10/Modules/FindJNI.cmake:310 (FIND_PACKAGE_HANDLE_STANDARD_ARGS) CMakeLists.txt:37 (find_package) -- Configuring incomplete, errors occurred! See also "/scratch/vpp-tmp/build-root/build-vpp-native/japi/CMakeFiles/CMakeOutput.log". See also "/scratch/vpp-tmp/build-root/build-vpp-native/japi/CMakeFiles/CMakeError.log". Makefile:640: recipe for target 'japi-configure' failed make[2]: *** [japi-configure] Error 1 make[2]: Leaving directory '/scratch/vpp-tmp/build-root' This reverts commit a33db2528485ac39e8987bec7b138dbdad21dc5a. Change-Id: I8a818ce70a8379656c1134432e22db418a4690fe Signed-off-by: Damjan Marion <damarion@cisco.com>
Diffstat (limited to 'extras/japi/CMakeLists.txt')
-rw-r--r--extras/japi/CMakeLists.txt42
1 files changed, 0 insertions, 42 deletions
diff --git a/extras/japi/CMakeLists.txt b/extras/japi/CMakeLists.txt
deleted file mode 100644
index a0bcf5e515d..00000000000
--- a/extras/japi/CMakeLists.txt
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright (c) 2018 Cisco and/or its affiliates.
-# Licensed under the Apache License, Version 2.0 (the "License");
-# you may not use this file except in compliance with the License.
-# You may obtain a copy of the License at:
-#
-# http://www.apache.org/licenses/LICENSE-2.0
-#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS,
-# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
-# See the License for the specific language governing permissions and
-# limitations under the License.
-
-cmake_minimum_required(VERSION 3.5 FATAL_ERROR)
-
-project(japi VERSION 18.10)
-
-include(CheckCCompilerFlag)
-
-if(CMAKE_SYSTEM_PROCESSOR MATCHES "amd64.*|x86_64.*|AMD64.*")
- set(CMAKE_C_FLAGS "-march=corei7 -mtune=corei7-avx ${CMAKE_C_FLAGS}")
-elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "^(aarch64.*|AARCH64.*)")
- set(CMAKE_C_FLAGS "-march=armv8-a+crc ${CMAKE_C_FLAGS}")
-endif()
-
-check_c_compiler_flag("-Wno-address-of-packed-member" compiler_flag_no_address_of_packed_member)
-if (compiler_flag_no_address_of_packed_member)
- add_definitions(-Wno-address-of-packed-member)
-endif()
-
-set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/lib)
-set(CMAKE_INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
-set(CMAKE_INSTALL_MESSAGE NEVER)
-
-find_package(Threads REQUIRED)
-find_package(Java 1.8 REQUIRED COMPONENTS Development)
-find_package(JNI REQUIRED)
-
-message("Found java headers ${JNI_INCLUDE_DIRS}")
-message("Found javac at: " ${Java_JAVAC_EXECUTABLE})
-
-add_subdirectory(java)