aboutsummaryrefslogtreecommitdiffstats
path: root/extras/rpm/vpp.spec
diff options
context:
space:
mode:
authorRenato Botelho do Couto <renato@netgate.com>2017-11-30 15:41:22 -0600
committerDamjan Marion <dmarion.lists@gmail.com>2017-12-04 11:36:28 +0000
commite266ea3795747910127e189c5d341b93bb778091 (patch)
tree38f56730e808802e7e6cb2ccc63cc5bec5545885 /extras/rpm/vpp.spec
parent37eba0db4262eb5cb63be8911f1af845b845739b (diff)
Optimize RPM build process
* Remove unused variable OS_VERSION_ID * Do all RPM building in build-root/rpmbuild * Add build-root/rpmbuild to .gitignore * Move redundant code to a target called 'spec' * Copy spec file to SPECS instead of SOURCES * Only set %{_topdir} macro when it's undefined, and because of that remove sed call to delete definition on spec file * Pass _version and _release using --define parameter instead of using sed to add them to .spec * Move rpm files to build-root after build finishes * Add dist tarball to .gitignore Change-Id: I230d60b62914056b353f7f8701d14754b0bf7f8c Signed-off-by: Renato Botelho do Couto <renato@netgate.com>
Diffstat (limited to 'extras/rpm/vpp.spec')
-rw-r--r--extras/rpm/vpp.spec2
1 files changed, 1 insertions, 1 deletions
diff --git a/extras/rpm/vpp.spec b/extras/rpm/vpp.spec
index b200df7ee82..6bdecb4de43 100644
--- a/extras/rpm/vpp.spec
+++ b/extras/rpm/vpp.spec
@@ -1,7 +1,7 @@
%bcond_without aesni
+%{!?_topdir:%define _topdir %(pwd)}
%define _vpp_build_dir build-tool-native
%define _unitdir /lib/systemd/system
-%define _topdir %(pwd)
%define _builddir %{_topdir}
%define _tmp_build_dir %{name}-%{_version}.0
%define _mu_build_dir %{_topdir}/%{_tmp_build_dir}/build-root