aboutsummaryrefslogtreecommitdiffstats
path: root/extras/vom/CMakeLists.txt
diff options
context:
space:
mode:
authorMohsin Kazmi <sykazmi@cisco.com>2018-11-21 19:00:46 +0100
committerNeale Ranns <nranns@cisco.com>2018-12-13 07:46:02 +0000
commit51edc3ab01e0af58d457da97bf6ca9cc3ebc6b8d (patch)
tree61030afdb69ed1952021dad99fa209a280d68a49 /extras/vom/CMakeLists.txt
parenteb6c7999477cfbca77223be3ef7f11528da9f093 (diff)
vom: Add support for new stats
This patch deprecates old stats and adds support for new stats. This implements the PULL design where client will enable stats on objects (i.e. interfaces, etc), register a call back function which will run once stats will be ready for enabled object and call HW::read_stats() periodically to read stats for enabled objects from VPP. Change-Id: I32525a417427be87408d01f8bc93a731602ff690 Signed-off-by: Mohsin Kazmi <sykazmi@cisco.com>
Diffstat (limited to 'extras/vom/CMakeLists.txt')
-rw-r--r--extras/vom/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/extras/vom/CMakeLists.txt b/extras/vom/CMakeLists.txt
index 6ed14cd75a2..a04df5d52ab 100644
--- a/extras/vom/CMakeLists.txt
+++ b/extras/vom/CMakeLists.txt
@@ -24,6 +24,7 @@ set(CMAKE_INSTALL_MESSAGE NEVER)
find_package(VPP)
find_package(Threads REQUIRED)
+find_package(Boost OPTIONAL_COMPONENTS system filesystem)
add_subdirectory(vom)