aboutsummaryrefslogtreecommitdiffstats
path: root/extras/vom/CMakeLists.txt
diff options
context:
space:
mode:
authorNeale Ranns <nranns@cisco.com>2019-07-30 06:20:39 -0700
committerAndrew Yourtchenko <ayourtch@gmail.com>2019-08-07 08:54:43 +0000
commite3282bae27064b3d9788e235db50441fd2fe1a70 (patch)
tree9d1977d3eb9409f8d542c99cf3cd6bde7523ebf9 /extras/vom/CMakeLists.txt
parentd5d7b96ec157a44dda2753a4f9c49cc40a76e1f7 (diff)
vom: export/install cmake files
Type: feature allow other projects to use cmake modules to find VOM Change-Id: I00e01e9bec3ecf79903cd522d2770bdb70e5399b Signed-off-by: Neale Ranns <nranns@cisco.com>
Diffstat (limited to 'extras/vom/CMakeLists.txt')
-rw-r--r--extras/vom/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/extras/vom/CMakeLists.txt b/extras/vom/CMakeLists.txt
index 3a32117882a..4947235717e 100644
--- a/extras/vom/CMakeLists.txt
+++ b/extras/vom/CMakeLists.txt
@@ -26,6 +26,7 @@ execute_process(
OUTPUT_STRIP_TRAILING_WHITESPACE
)
+set(CMAKE_MODULE_PATH ${CMAKE_MODULE_PATH} "${CMAKE_CURRENT_SOURCE_DIR}/cmake")
set(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -g")
set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/lib)
set(CMAKE_INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
@@ -36,6 +37,7 @@ find_package(Threads REQUIRED)
find_package(Boost OPTIONAL_COMPONENTS system filesystem)
add_subdirectory(vom)
+add_subdirectory(cmake)
add_vpp_packaging(
NAME "vom"