summaryrefslogtreecommitdiffstats
path: root/extras/vom/vom/CMakeLists.txt
diff options
context:
space:
mode:
authorNeale Ranns <nranns@cisco.com>2019-02-22 00:44:40 -0800
committerNeale Ranns <nranns@cisco.com>2019-02-22 15:41:51 +0000
commit5637e653649692eb04fbec5c97e0fd427404c1dd (patch)
tree72105c0ee0e85ad17305e8cf98cbe0e08294e5e5 /extras/vom/vom/CMakeLists.txt
parentba94462c42a27f7447e10ca55a3b212970448ceb (diff)
VOM: De-template the ACL code.
there's something going wrong with the dependency ordering. i have added hacks in the past, but these are not reliable across compiler versions. Change-Id: I34b4aae4c7ed7beaa424cd692ff34cba21ba802a Signed-off-by: Neale Ranns <nranns@cisco.com>
Diffstat (limited to 'extras/vom/vom/CMakeLists.txt')
-rw-r--r--extras/vom/vom/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/extras/vom/vom/CMakeLists.txt b/extras/vom/vom/CMakeLists.txt
index a0a5f9783e9..26dd3e46574 100644
--- a/extras/vom/vom/CMakeLists.txt
+++ b/extras/vom/vom/CMakeLists.txt
@@ -50,10 +50,11 @@ if(ACL_FILE)
acl_binding.cpp
acl_ethertype_cmds.cpp
acl_ethertype.cpp
+ acl_l2_list.cpp
acl_l2_rule.cpp
+ acl_l3_list.cpp
acl_l3_rule.cpp
acl_list_cmds.cpp
- acl_list.cpp
acl_types.cpp
)
endif()
@@ -189,7 +190,8 @@ if(ACL_FILE)
acl_ethertype.hpp
acl_l2_rule.hpp
acl_l3_rule.hpp
- acl_list.hpp
+ acl_l3_list.hpp
+ acl_l2_list.hpp
acl_types.hpp
)
endif()