summaryrefslogtreecommitdiffstats
path: root/plugins/Makefile.am
diff options
context:
space:
mode:
authorDave Barach <dave@barachs.net>2016-07-02 10:34:55 -0400
committerDave Barach <dave@barachs.net>2016-07-02 10:35:08 -0400
commitdbacf85fed57839b58ad10605a5245ebe6c1a049 (patch)
tree4780bd07178f0cd8d173b92deca822b468b791c9 /plugins/Makefile.am
parenta15568029aecb3c1da582c8662702edd502bee72 (diff)
Finish cleanup of .../plugins/{configure.ac, Makefile.am}
To add a new plugin subdirectory, add this to Makefile.am: if ENABLE_new_PLUGIN SUBDIRS += new-plugin endif and add this to configure.ac: PLUGIN(new) Change-Id: I770a6f4f8f964fd7318a912be486accf46514b59 Signed-off-by: Dave Barach <dave@barachs.net>
Diffstat (limited to 'plugins/Makefile.am')
-rw-r--r--plugins/Makefile.am20
1 files changed, 15 insertions, 5 deletions
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
index 83dc70bfeda..350a00e3c3f 100644
--- a/plugins/Makefile.am
+++ b/plugins/Makefile.am
@@ -13,23 +13,33 @@
AUTOMAKE_OPTIONS = foreign subdir-objects
+# To add a new plugin subdirectory:
+#
+# add a stanza here:
+# if ENABLE_new_PLUGIN
+# SUBDIRS += new-plugin
+# endif
+#
+# Also: add PLUGIN(new) to configure.ac
+
SUBDIRS =
-if ENABLE_SAMPLE_PLUGIN
+
+if ENABLE_sample_PLUGIN
SUBDIRS += sample-plugin
endif
-if ENABLE_SIXRD_PLUGIN
+if ENABLE_sixrd_PLUGIN
SUBDIRS += sixrd-plugin
endif
-if ENABLE_IOAM_PLUGIN
+if ENABLE_ioam_PLUGIN
SUBDIRS += ioam-plugin
endif
-if ENABLE_VCGN_PLUGIN
+if ENABLE_vcgn_PLUGIN
SUBDIRS += vcgn-plugin
endif
-if ENABLE_SNAT_PLUGIN
+if ENABLE_snat_PLUGIN
SUBDIRS += snat-plugin
endif