summaryrefslogtreecommitdiffstats
path: root/plugins/lb-plugin/Makefile.am
diff options
context:
space:
mode:
authorPierre Pfister <ppfister@cisco.com>2016-08-04 16:13:09 +0100
committerDave Barach <openvpp@barachs.net>2016-08-11 14:05:40 +0000
commit041eacc81656d2ed5bc01b96b15a7d03a1700f13 (patch)
treef1cded1a27f92bab90fec8e5ea9d991ee2ff7eb5 /plugins/lb-plugin/Makefile.am
parent3590ac5881261c95a3c575360e24903d60fac392 (diff)
VPP-130: MagLev-like Load Balancer
This plugin provides load balancing for VPP in a way that is largely inspired from Google's MagLev: http://research.google.com/pubs/pub44824.html More info in the README.md Change-Id: I1223f495d5c2d5200808a398504119f2830337e9 Signed-off-by: Pierre Pfister <ppfister@cisco.com>
Diffstat (limited to 'plugins/lb-plugin/Makefile.am')
-rw-r--r--plugins/lb-plugin/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/plugins/lb-plugin/Makefile.am b/plugins/lb-plugin/Makefile.am
new file mode 100644
index 00000000000..8d92ff1dfc4
--- /dev/null
+++ b/plugins/lb-plugin/Makefile.am
@@ -0,0 +1,42 @@
+# Copyright (c) 2016 Cisco Systems, Inc.
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at:
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+AUTOMAKE_OPTIONS = foreign subdir-objects
+
+AM_CFLAGS = -Wall
+AM_LDFLAGS = -module -shared -avoid-version
+
+vppapitestpluginsdir = ${libdir}/vpp_api_test_plugins
+vpppluginsdir = ${libdir}/vpp_plugins
+
+vppapitestplugins_LTLIBRARIES = lb_test_plugin.la
+vppplugins_LTLIBRARIES = lb_plugin.la
+
+lb_plugin_la_SOURCES = lb/lb.c lb/node.c lb/cli.c lb/util.c lb/refcount.c lb/api.c
+
+SUFFIXES = .api.h .api
+
+%.api.h: %.api
+ mkdir -p `dirname $@` ; \
+ $(CC) $(CPPFLAGS) -E -P -C -x c $^ \
+ | vppapigen --input - --output $@ --show-name $@
+
+noinst_HEADERS = lb/lb.h lb/util.h lb/refcount.h lb/lbhash.h lb/lb.api.h
+
+lb_test_plugin_la_SOURCES = \
+ lb/lb_test.c lb/lb_plugin.api.h
+
+# Remove *.la files
+install-data-hook:
+ @(cd $(vpppluginsdir) && $(RM) $(vppplugins_LTLIBRARIES))
+ @(cd $(vppapitestpluginsdir) && $(RM) $(vppapitestplugins_LTLIBRARIES))